Phoenix Datacenter Outage
Incident Report for System Uptime and Status Page
Resolved
This incident has been resolved.
Posted Jan 17, 2024 - 20:34 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 17, 2024 - 17:59 MST
Update
We are continuing to investigate this issue.
Posted Jan 17, 2024 - 17:55 MST
Update
We are working to resolve an issue in our Phoenix datacenter location. We are working with our partners to identify and remediate a facility issue affecting cloud services and hosted SaaS products.
Posted Jan 17, 2024 - 17:43 MST
Update
We are continuing to investigate this issue.
Posted Jan 17, 2024 - 17:38 MST
Investigating
We are currently investigating this issue.
Posted Jan 17, 2024 - 17:20 MST
This incident affected: US West (Cloud Service West, Hosting Hosting West, Email Services West, DNS Service West, Hosted VoIP Services).